Go Back   CruiseMates Cruise Community and Forums > Cruise Lines (Mainstream) > Celebrity
Register Forgot Password?

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old April 22nd, 2001, 09:31 PM
Senior Member
First Mate
 
Join Date: Sep 2000
Posts: 297
Default Millie update

Seems the shipyard fixed the engine problem -- we got into all ports on time ( ahead of schedule at times)

Vibrations?? Didnt notice any except when the ship was turning around .
Reply With Quote
Sponsored Links
Reply

Bookmarks

Similar Threads
Thread Thread Starter Forum Replies Last Post
Millie 01/02/05 amva Celebrity 3 November 29th, 2004 04:25 PM
millie 5/9/04 szn Celebrity 4 January 30th, 2004 11:21 AM
UPDATE! UPDATE! _RIFLE FOUND!!! Carole and Johnny Chit - Chat for Cruisers 4 October 24th, 2002 04:32 PM
To Millie or not to Millie? need_A_vacation Celebrity 9 June 16th, 2002 04:51 PM
MILLIE UPDATE 4/15 FRANK C Celebrity 0 April 23rd, 2001 01:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


 

All times are GMT -4. The time now is 05:01 PM.
design by: Themes by Design

Powered by vBulletin® Version 3.8.7 Beta 1
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1